This issue has been resolved, Rewards are now accessible.
Posted Nov 21, 2025 - 13:47 MST
Investigating
We are currently investigating an issue some users are having when attempting to access the Rewards Catalog. We will provide updates as soon as they become available.
Posted Nov 21, 2025 - 13:38 MST
This incident affected: Bonusly Platform (Rewards).