Unexpected downtime
Incident Report for bonusly
Resolved
This incident has been resolved.
Posted 6 months ago. Aug 12, 2018 - 22:22 MDT
Investigating
We are currently experiencing some unexpected downtime. Our engineers are working on a fix right now.
Posted 6 months ago. Aug 12, 2018 - 22:20 MDT
This incident affected: Web.