Bonusly rewards are temporarily unavailable.

Incident Report for bonusly

Resolved

This issue has been resolved.
Posted Aug 03, 2023 - 16:24 MDT

Investigating

We are currently investigating this issue.
Posted Aug 03, 2023 - 15:59 MDT
This incident affected: Bonusly Platform (Rewards).