Amazon Gift Cards Temporarily Disabled
Incident Report for bonusly
Resolved
And we're back!
Posted 22 days ago. Sep 24, 2019 - 09:00 MDT
Investigating
We are having an issue with the Amazon gift cards API and have had to temporarily disable these rewards.
Posted 22 days ago. Sep 24, 2019 - 08:32 MDT
This incident affected: Rewards.