PayPal rewards temporarily unavailable

Incident Report for bonusly

Resolved

This incident has been resolved.
Posted Jun 17, 2020 - 09:03 MDT

Investigating

We are currently investigating this issue.
Posted Jun 16, 2020 - 13:38 MDT
This incident affected: Bonusly Platform (Rewards).