We identified a slow query in our rewards infrastructure and implemented a query improvement to resolve.
Posted Apr 07, 2026 - 09:57 MDT
Investigating
We are currently experiencing intermittent issues with rewards redemption. Some users may encounter timeouts or delays when attempting to redeem rewards. Our engineering team is actively investigating the root cause. We will provide updates as we learn more.
Posted Apr 07, 2026 - 07:01 MDT
This incident affected: Bonusly Platform (Rewards).