Job Processing Delays
Incident Report for bonusly
Resolved
This incident has been resolved.
Posted 7 months ago. Sep 28, 2018 - 17:00 MDT
Investigating
We are experiencing issues with delayed job processing. Expect emails and slack notifications to be delayed.
Posted 7 months ago. Sep 28, 2018 - 15:09 MDT