Problems fulfilling some rewards
Incident Report for bonusly
Resolved
This issue has been resolved by our provider.
Posted about 2 years ago. Oct 03, 2017 - 10:59 MDT
Identified
Our provider has identified the problem and is working on a fix. Currently most rewards are going through but we are still seeing intermittent failures.
Posted about 2 years ago. Oct 03, 2017 - 10:26 MDT
Investigating
One of our providers is having issues fulfilling rewards. We currently investigating. Sorry for any inconvenience.
Posted about 2 years ago. Oct 03, 2017 - 08:16 MDT