Bonusly Failing to Load
Incident Report for bonusly
Resolved
This incident has been resolved!
Posted Apr 19, 2022 - 10:41 MDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 18, 2022 - 12:57 MDT
Investigating
We are currently investigating an issue where users may be unable to access Bonusly via a web browser.
Posted Apr 18, 2022 - 12:55 MDT
This incident affected: Web.