Rewards Catalog Latency

Incident Report for bonusly

Resolved

A fix has been implemented and this incident has been resolved.
Posted Mar 11, 2025 - 10:45 MDT

Identified

We are actively working to address a recently reported performance issue, which may result in slowness or errors when accessing Rewards. We apologize for the inconvenience and will share updates on this page as they become available.
Posted Mar 11, 2025 - 09:48 MDT
This incident affected: Rewards.