Activity Feed Performance Issue

Incident Report for bonusly

Resolved

Monitoring the situation confirms performance is nominal. Thanks for your patience!
Posted Mar 06, 2026 - 16:49 MST

Monitoring

Performance has stabilized - Our teams will continue to monitor.
Posted Mar 06, 2026 - 10:34 MST

Investigating

We are currently investigating reports of slowness impacting the activity feeds on the Bonusly homepage. Please monitor this thread for updates.
Posted Mar 06, 2026 - 10:16 MST