Some rewards temporarily unavailable
Incident Report for bonusly
Resolved
This incident has been resolved.
Posted over 1 year ago. Jan 23, 2018 - 11:05 MST
Investigating
Our rewards provider is having issues providing certain rewards, such as Amazon gift cards.
Posted over 1 year ago. Jan 23, 2018 - 10:56 MST