Some rewards are currently unavailable :(
Incident Report for bonusly
Resolved
The rewards catalog is fully available again.
Posted May 22, 2017 - 12:14 MDT
Investigating
One of our rewards providers is currently having issues and many of our rewards are currently unavailable. Apologies for the inconvenience.
Posted May 22, 2017 - 11:39 MDT